1
0
-1
install-and-update.sh script gives following error message.


Translate5 installation check - module database
===============================================

Database : problematic

[ERROR] Your DB timezone (GMT +03:00) and your PHP timezone (GMT +02:00) differ! Please ensure that PHP (apache and CLI) timezone is set correctly and the DBs timezone is the same!

Fix the errors and call the script again!

I have checked my settings first

root@t5:/var/www/translate5# grep -r '/etc/php/7.3/' -e "date.timezone ="
/etc/php/7.3/apache2/php.ini:date.timezone = "Europe/Tallinn"
/etc/php/7.3/cli/php.ini:date.timezone = "Europe/Tallinn"
root@t5:/var/www/translate5# grep -r -e "Your DB timezone"

points to application/modules/default/Models/SystemRequirement/Modules/Database.php

I have added 

$phpZone = date('P');
        echo 'date.timezone: ' . ini_get('date.timezone');

which gives

Translate5 installation check - module database
===============================================

date.timezone: Europe/Vienna Database : problematic

root@t5:/var/www/translate5# grep -r -e "Europe/Vienna"

points to application/config/application.ini, where

 phpSettings.date.timezone = "Europe/Vienna" ;

disabling it allows script to access system php settings.

    CommentAdd your comment...

    1 answer

    1.  
      1
      0
      -1

      This is indeed an error, I will create an issue so that the timezone is checked in system check, and is removed from app.ini

        CommentAdd your comment...